[reportlab-users] ReportLab 2.0 and 1.21 .tgz files on site corrupted?

Andy Robinson andy at reportlab.com
Tue Aug 1 12:06:58 EDT 2006

Vasudev Ram wrote:
> Hi list,
> Tried downloading them (ReportLab 2.0 and 1.21 .tgz files - from the 
> ReportLab.org site) a couple of times, recently.
> Download went ok. When I tried to unzip with WinZip, showed the same 
> file name (the .tgz) recursively inside the original .tgz after 
> expanding to .tar. Then when I double-clicked on this second (embedded) 
> .tgz file, it showed an Add to Zip file dialog, instead of extracting it.
> This happened both times, for both the 2.0 and 1.21 .tgz's.
> What's up?

You're right.  The .tgz also won't open with unzip.exe on Windows

The .zip works absolutely fine, and the .tgz unzipped nicely on a Linux 
box just now, so I guess this may be a subtle incompatibility between 
our tar or gz code and Windows untarring code.

Our build guru is on holiday and back on Monday, but I've put this in 
the issue tracker for him as a "medium priority" when he's back.

In the meantime the .zip file works fine, I hope this helps you
for now.

Best Regards,

Andy Robinson

More information about the reportlab-users mailing list