[reportlab-users] ReportLab and PyPy

Marius Gedminas marius at gedmin.as
Mon Nov 23 06:51:01 EST 2015

On Mon, Nov 23, 2015 at 10:33:29AM +0000, Robin Becker wrote:
> On 23/11/2015 09:08, Marius Gedminas wrote:
> >Is anyone using ReportLab with PyPy?
> >
> >I ask because I'm seeing a strange segfault with PyPy 4.0.1-alpha0:
> >https://travis-ci.org/mgedmin/mgp2pdf/jobs/91417380
> I did run some trials of reportlab with pypy a while back and it was mostly
> working. I nevert tried out with an alpha though :)

It's what the PyPy folks had published in their PPA as the "4.0.0 final"
version.  No idea why it's calling itself 4.0.1-alpha0.

There's now a 4.0.1 final in the PyPy PPA but Travis seems to have the
apt lists cached and still gets the older 4.0.1-alpha0.

> I looked at the travis thing, but it looked like double dutch to me, my best
> interpretation is that something went wrong with
> https://github.com/mgedmin/mgp2pdf.git, but looking there I see that 6 days
> ago you dropped the pypy support in the code.

I added pypy to my .travis.yml, then tried to get it working (pushing
ad-hoc commits to a 'travis' branch), then removed it from the 'master'
branch because of this segfault.

I cannot reproduce the segfault on my laptop (Ubuntu 15.10, pypy from
the same PPA as on Travis).

> I will try and set up a pypy  test in the near future. I'm almost certain
> last time I tried the failures were mostly to do with pil/pillow. You seem
> to have no trouble with pillow as you commented


> >"Assuming it's ReportLab and not, say, Pillow -- but imgdiff's tests
> >work on pypy"
> According to
> https://bitbucket.org/pypy/compatibility/wiki/reportlab%20toolkit
> RL is compatible, but my naive attempts to do pip install reportlab fail
> when trying to do extension compilations so it can't be that compatible.

Oh, interesting.  Which PyPy version did you try?  I've tried several
(pypy as packaged in Ubuntu 12.04, 14.04, 15.10 and the PPA), and I
never got compilation errors -- just runtime errors (with PyPy 2.5.0),
and now this segfault.

BTW that "Fatal RPython error: AssertionError" in the commit message you
quoted was actually totally my fault: I had a cached ReportLab binary
wheel built against PyPy 2.6.0, which was still being used after I
upgraded to PyPy 4.0.0.  (It's actually a bug in pip/setuptools/the
whole Python packaging mess that doesn't bake the PyPy version in the
binary wheel filename abi tag portion.  Will be fixed someday, maybe.)

Marius Gedminas
Was a time, all we got for christmas were bitfields. And we were happy!
                -- Mike Barton
You had bitfields? When I wanted more bits I had to pull out my wirewrap tool
and put them in myself!
                -- Andrew Dalke
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 173 bytes
Desc: Digital signature
URL: <https://pairlist2.pair.net/pipermail/reportlab-users/attachments/20151123/057f7810/attachment.pgp>

More information about the reportlab-users mailing list