[reportlab-users] Problems installing Reportlab

Christopher Brewster cbrewster at gmail.com
Thu Aug 6 12:05:42 EDT 2009

It is 2.6 downloaded from Python.org
I thought that is what one is supposed to do (use the latest
version ....)

There does seem to be a problem with PIL and 2.6 though. I am about to
query the Image-SIG.


On 6 Aug 2009, at 18:00, Bill Janssen wrote:

Robin Becker <robin at reportlab.com> wrote:

> Christopher Brewster wrote:

>> On a Macbook Pro running Leopard, I have PIL and Freetype2 installed.

>> When I run "python setup.py install" I get the following:

>> ---

> ...........

>> This appears to be good but when I run "python setup.py tests" I get

>> the messages below.

>> Is there anything I have done wrong or what?


>> Thanks for your advice.


>> Christopher


> Could this be a line ending conversion error. We don't make MAC

> specific archives. I always assumed that people used the tar.gz files

> and that being some kind of unix the mac versions just worked like

> unix. the import and PIL errors are reminiscent of problem we get when

> line endings are converted wrongly.

Doubt it. I build ReportLab from source on my Mac pretty much every day
-- as you say, it's pretty much UNIX.

Note that the OP is using some other flavor of Python -- it's 2.6, and
2.5 is what OS X 10.5 comes with. Looks like a third-party Python, not
the one that ships with the Mac. Maybe it's built wrong.

reportlab-users mailing list
reportlab-users at reportlab.com

More information about the reportlab-users mailing list