[reportlab-users] Umlaut Bug with Adobe Reader and Arial

Robin Becker robin at reportlab.com
Thu May 29 05:50:05 EDT 2014

On 23/05/2014 14:01, Volker Haas wrote:
> I just realized that the ttfAsciiReadable=0 trick does only work in the
> minimal example script I posted. If I use it in our rendering stack the
> fix does not work (I am confident that I am actually changing the
> configuration since the PDF files are significantly smaller after
> setting ttfAsciiReadable=0).
> Therefore my question is: if you think this is a bug in reportlab, do
> you plan on fixing it?
Volker I've had a good look at the ttfonts code. I found one issue which might 
explain some of the warnings I get from Acrobat Preflight, but I still have the 
issue with the umlauts. I have tried making PDF with various other tools, but 
have very little luck in duplicating this behaviour. I can get very small 
embedded fonts from Inkscape and they seem to work OK with the minimal example. 
Their embedding scheme is a bit different and it's not clear why there's any 
improvement in display for the trivial example.

Do you have other longer examples where the umlaut display is broken?

Interestingly neither the embedded inkscape or our embedded ttf are recognized 
as truetype fonts by windows XP although fontforge & fontools are happy to read 

As an experiment I went back to an earlier era and tried one of my failing PDFs 
on Acrobat reader 4.05 and lo and behold it works fine there. I don't know when 
this started to fail, but it's definitely wrong in Acrobat Reader 9


-still mystified-ly yrs-
Robin Becker

More information about the reportlab-users mailing list