[reportlab-users] pyRXP - strange non-deterministic errors on python 2.7 and 64-bit Linux

Robin Becker robin at reportlab.com
Tue May 17 11:18:56 EDT 2011

On 17/05/2011 15:27, Roger Whittaker wrote:

> On Tue, May 17, 2011 at 03:07:44PM +0100, Robin Becker wrote:


>> I tried the withcallback script on XUBUNTU 11.04 (it has gcc 4.5.2)

>> with no errors. I used the latest pyrxp tarzip and virtualenv to

>> create a private environment. Then python setup.py install did the

>> trick in the activated environment.


> What is virtualenv?

just a method to allow me to create a local copy of the python environment, then
I can update with whatever python packages and tear down without worrying about
the system as a whole. So I ran

virtualenv bug000 #create a new python2.7 environment
cd bug000
. bin/activate #make ours the python in the environment
wget http://www.reportlab.com/ftp/pyRXP-1.14-daily-unix.tar.gz
tar xvf ../pyRXP-1.14-daily-unix.tar.gz
cd pyRXP-1.14/
python setup.py install
cd ..
mkdir test
cd test
cp ~/tmp/bugfiles/* .
python withcallback.py foo.xml

> By "did the trick" you mean that you have replicated the issue?


NO there are no errors when running that withcallback script so I am unable to


> ii libc6 2.13-0ubuntu13 Embedded GNU C Library: Shared libraries


I have the same version.
Robin Becker

More information about the reportlab-users mailing list