[reportlab-users] pyRXP - strange non-deterministic errors on python 2.7 and 64-bit Linux

Robin Becker robin at reportlab.com
Thu May 12 05:19:27 EDT 2011

On 11/05/2011 21:10, Tim Roberts wrote:

> Roger Whittaker wrote:

>> I'm not sure if this is the right place to ask this question, but

>> I'm hoping it might be - any help gratefully received.


>> I've been using pyRXP for some years without problems.


>> I recently reinstalled it

>> (http://www.reportlab.com/ftp/pyRXP-1.14-daily-unix.tar.gz) on

>> newly installed 64-bit Linux (openSUSE 11.4 with

>> gcc-4.5-19.1.x86_64, glibc-2.11.3-12.15.1.x86_64, python 2.7).


>> I am seeing really strange behaviour (I can't reproduce this on

>> 32-bit Linux with the same package versions).


> For what it's worth, I just tried your exact code on Linux 64 with

> Python 2.4 and it worked as expected. I got the same warnings during

> compilation.


It might be of interest to know the values of sys.maxunicode. On my x64 systems
I think we still have 16bit unicode so that

$ python25 -c"import sys;print sys.maxint,sys.maxunicode"
9223372036854775807 65535

I think that means configured with --enable-unicode=ucs2

rxp the internal library uses a 16bit wide character type internally so perhaps
there's a bug lurking in there somewhere.
Robin Becker

More information about the reportlab-users mailing list