[reportlab-users] bus error with renderPM

Robin Becker robin at reportlab.com
Thu Nov 25 13:28:05 EST 2004

Robin Becker wrote:
> Craig Jacobs wrote:
>> I am trying out reportlab and am using mac OS X. I seem to able to run 
>> reportlab without any trouble, but when i try the test_renderPM script 
>> i get a bus error. I have PIL installed. Any idea what could be 
>> causing the trouble? Thanks!
>> -Craig
> mmhhh I don't seem to have a test renderPM script. Do you have a 
> compiled version of the _renderPM.c file?
Being amazingly stupid I forgot to look for the test_renderPM script where it 
lives in the rl_addons/renderPM location.

OK I tried the test_renderPM script with our 2.3 Mac version and that also bus 

On my build file produces this

$ file _renderPM.o
_renderPM.o: Mach-O object ppc

so clearly we have an architectural difference. On the other hand our whole 
effort was aimed at getting the whole of python and reportlab & friends into
a single dylib for a client. Amazingly it all worked. I doubt the bundle 
approach would have been much use, but perhaps others can enlighten me.

The good news is that I also get a fault on win32 running the script. However, I 
don't know where the problem is. It's possible it's in PIL for which I'm not 
responsible. I will have to do more checking. I'm certainly using most of 
_renderPM without problem so it must be something fairly obscure.

> We have built all the extensions for OS X, but I'm not an expert on the 
> so called standard Python build and we just used the old cnfigure make 
> dance.

Robin Becker

More information about the reportlab-users mailing list