[reportlab-users] "setfont" tag in RML seems not to work propelry

Robin Becker reportlab-users@reportlab.com
Tue, 20 Jul 2004 09:41:31 +0100

Robin Becker wrote:

>> I am using Python 2.3; may this cause the problem ?
>> I am looking forward to your advice!
>> Ulrich Weber
> Ulrich I tried this exact source with the current SVN version of 
> rml2pdf/reportlab and it works perfectly (as expected) with Python 2.3 
> under win32 and freebsd. Since Helvetica-Bold is one of the standard 
> fonts it should be available always.
> Is it possible that your source text is encoded in some way? I can't 
> seem to find character 0x93 in your example probably. When I use that 
> character explicitly pasted in (it seems to be a special double quote) I 
> still get a working PDF.
> Can you say which version or rml2pdf/reportlab you are using?

my colleague points out that your traceback seems to indicate that you're using 
someone elses version of rml2pdf eg

   File "D:\AR_Tool\AR_Tool_V9.1\AR_Tool\Script1.py", line 27, in ?
     x = parseString(rml)
   File "trml2pdf\trml2pdf.py", line 518, in parseString
   File "trml2pdf\trml2pdf.py", line 148, in render
   File "trml2pdf\trml2pdf.py", line 507, in render

in which case all bets are off. You probably better consult the author directly.
Robin Becker