[reportlab-users] Anybody else hungry for Image shapes?

Robin Becker reportlab-users@reportlab.com
Sat, 27 Jul 2002 15:36:19 +0100

In article <4900E396-A16A-11D6-ADFF-00039345C610@darwin.in-berlin.de>, Dinu Gherman
<gherman@darwin.in-berlin.de> writes
>Robin Becker:
>> well since I posted y'day I've heard nothing. I guess that could mean
>> utter indifference or complete satisfaction (at least with renderPM).
>> Last time I changed _renderPM.c/libart it was quite badly broken and
>> there was still no uproar.
>I just made a CVS checkout/update and tried to compile it on OS X.
>In the absence of a README I simply tried "python setup.py build"
>which results in the error below. Not sure, if this is my own en-
>vironment to be blamed, but I remember it used to compile on it
>some day. But pyRXP does compile compile now (as it did before).
>[localhost:~/Desktop/renderPM] dinu% python setup.py build
>running build_ext
>building '_renderPM' extension
>cc -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -no-cpp-precomp 
>-DLIBART_COMPILATION -DLIBART_VERSION=\"2.3.10\" -I. -I./libart_lgpl 
>-I./gt1 -I/usr/local/include/python2.2 -c _renderPM.c -o 
>build/temp.darwin-5.5-Power Macintosh-2.2/_renderPM.o
>_renderPM.c:0: unterminated string or character constant
>_renderPM.c:0: possible real start of unterminated constant
>error: command 'cc' failed with exit status 1
>[localhost:~/Desktop/renderPM] dinu%

this looks like some kind of distutils problem.
There are some long string constants, but I don't 
think there are any real unterminateds in this code.

I suspect the option -DLIBART_VERSION=\"2.3.10\"

When I use distutils on freeBSD I get that error, but if I
copy the compile command above and paste into my xterm the
command works fine. The \" is required on M$ win32.
If I change setup.py line 11 from
        return '\\"%s\\"' % string.join(map(lambda k,D=D: D.get(k,'?'),K),'.')

        return '"%s"' % string.join(map(lambda k,D=D: D.get(k,'?'),K),'.')

then things work fine.
Robin Becker