[DogParkList] Odd issue with MLDX 5.03

Steve Hellyer va3sph at mac.com
Sat Mar 28 21:22:17 EDT 2009

Larry if you get that again try open up Activity monitor and see if
some other application is consuming CPU most of your CPU. You can sort
the Activity monitor list by CPU by clicking on CPU column header.

You may notice an application running in that list called spindump.
This OS application kicks in when as a running progress becomes
unresponsive (hung).
Details here on what it does... http://developer.apple.com/documentation/Darwin/Reference/Manpages/man8/spindump.8.html

Console log is also a good friend here as you can usually see some
type of trail of complaints from OS or applications.

This is not a solution but just some tools and techniques to gather
more information on what might be occurring during these situations.

Lastly make sure your MicroHAM USB II drivers (FTDI serial chip) are
up to date http://www.microham.com/index1.html
But you sound like a fellow who keeps things quite current and may
have check this already.

Steve - VA3SPH

On 22-Mar-09, at 9:50 AM, Larry West wrote:

> MLDX 5.03 has been, by and large, working fine for me since I

> upgraded a short time ago. But I have been seeing some odd "lockups".


> Essentially what happens is MLDX will be the foreground app, and for

> no apparent reason, I get the "spinning beach ball of death", and

> MLDX is largely unresponsive.

> I can switch to other apps, and all seems to be working. I can even

> switch back to MLDX, and the window comes to the foreground, but I

> cannot do anything with it. Tuning the rig does not change the

> frequency display in MLDX. Dis- and re- connecting the USB II from

> the USB bus does not do anything.


> Sometimes MLDX will run for hours, sometimes, for only a brief

> period before locking up. The closest thing I can come with as to a

> cause is the lockup seems to mostly happen while I'm absent-mindedly

> tuning the rig using the tuning knob on the rig. But I'm not exactly

> 100% on that. Of course, it seems to only lock up when I need to log

> a contact!


> I have tried to force-quit MLDX, but that does not quite get rid of

> everything. The app window goes away, but the icon in the dock still

> shows the "active" glowing thingy below the icon. I can't relaunch

> MLDX, and I cannot restart or shut down, except with the power

> button on my MBP.


> I've tried the force-quit from the dock, and from Activity Monitor,

> and same result.


> System here is a 2.33 Ghz 15" MBP, 3Gig ram, Apple Cinema 20" ADC

> display, Apple Bluetooth keyboard & Mighty Mouse, Mac OS X 10.5.6

> I often run with MLDX, Mail.app, Safari, Acrobat Pro, and time

> Machine all active.

> Rig is an IC-7000, connected to the MBP via µHam USB II, and audio

> connected (for digital modes) via original iMic.


> I thought I spotted in another thread that there is a log I can send

> or look at, but I can't seem to locate the thread...


> 73,


> N2LJ

> Larry


> _______________________________________________

> DogParkList mailing list

> DogParkList at dogparksoftware.com

> http://two.pairlist.net/mailman/listinfo/dogparklist

More information about the DogParkList mailing list